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ДОДАТОК А 

 

КОД ФРЕЙМВОРКУ АВТОМАТИЗАЦІЇ 

 

from pywinauto import Desktop, Application 

import pyautogui 

import PIL 

import pytest 

import time 

import allure 

 

 

@allure.id(1) 

@allure.story("Simple test") 

@allure.title("test_integration_print_feature") 

def test_smoke_main_window(): 

    app = Application(backend="uia").start("notepad.exe") 

    dlg_main = app.UntitledNotepad 

    dlg_main.wait('visible') 

 

 

def test_smoke_open_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Open") 

    dlg_open = app.UntitledNotepad.Open 

    dlg_open.wait('visible') 

 

 

def test_smoke_save_as_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Save As") 

    dlg_save = app.UntitledNotepad.SaveAs 

    dlg_save.wait('visible') 

 

 

def test_smoke_font_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("Format->Font...") 

    dlg_font = app.UntitledNotepad.Font 

    dlg_font.wait('visible') 

     

     

def test_smoke_print_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Print") 

    dlg_print = app.UntitledNotepad.Print 

    dlg_print.wait('visible') 

     

     

def test_auto_main_window(): 

    app = Application(backend="uia").start("notepad.exe") 

    dlg_main = app.UntitledNotepad 

    dlg_main.wait('visible') 

    app.UntitledNotepad.menu_select("Help->About Notepad") 

    assert app.UntitledNotepad.AboutNotepad.Static2.texts() == ['Version 21H2 

(OS Build 19044.170)'] 

 

 

def test_auto_open_feature(): 
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    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Open") 

    dlg_open = app.UntitledNotepad.Open 

    dlg_open.Pane.wait('visible') 

    dlg_open.Static.wait('visible') 

    dlg_open.ComboBox.wait('visible') 

    dlg_open.ComboBox2.wait('visible') 

    dlg_open.Static3.wait('visible') 

    dlg_open.ComboBox3.wait('visible') 

    dlg_open.Open.wait('visible') 

    dlg_open.Cancel.wait('visible') 

    dlg_open.Pane5.wait('visible') 

    dlg_open.Pane6.wait('visible') 

    dlg_open.Pane7.wait('visible') 

    dlg_open.Pane9.wait('visible') 

    dlg_open.Pane10.wait('visible') 

    dlg_open.Pane11.wait('visible') 

    dlg_open.TitleBar.wait('visible') 

 

     

def test_auto_save_as_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Save As") 

    dlg_save = app.UntitledNotepad.SaveAs 

    dlg_save.wait('visible') 

    dlg_save.ComboBox.wait('visible') 

    dlg_save.Pane6.wait('visible') 

    dlg_save.Pane7.wait('visible') 

    dlg_save.Pane9.wait('visible') 

    dlg_save.Pane10.wait('visible') 

 

 

def test_auto_font_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("Format->Font...") 

    dlg_font = app.UntitledNotepad.Font 

    dlg_font.wait('visible') 

    dlg_font.Pane10.wait('visible') 

    dlg_font.Pane11.wait('visible') 

    dlg_font.TitleBar.wait('visible') 

    dlg_font.ComboBox2.wait('visible') 

    dlg_font.Static3.wait('visible') 

    dlg_font.ComboBox3.wait('visible') 

 

 

def test_auto_print_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Print") 

    dlg_print = app.UntitledNotepad.Print 

    dlg_print.wait('visible') 

    dlg_print.Pane11.wait('visible') 

    dlg_print.TitleBar.wait('visible') 

    dlg_print.ComboBox2.wait('visible') 

    dlg_print.Pane7.wait('visible') 

    dlg_print.Pane9.wait('visible') 

     

 

def test_functional_main_window(): 

    app = Application(backend="uia").start("notepad.exe") 

    pyautogui.write("Test22") 

    pic = pyautogui.screenshot() 

    pic.save('Screenshot3.png') 
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def test_functional_open_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Open") 

    dlg_open = app.UntitledNotepad.Open 

    dlg_open.wait('visible') 

    app.UntitledNotepad.Open.Cancel.click() 

    pyautogui.write('Test1.txt') 

    pyautogui.press('enter') 

    dlg_new_open = app.window(title='Test1.txt - Notepad') 

    dlg_new_open.wait('visible') 

 

 

def test_functional_save_as_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.type_keys("Anton") 

    app.UntitledNotepad.menu_select("File->Save As") 

    dlg_save = app.UntitledNotepad.SaveAs 

    dlg_save.wait('visible') 

    pyautogui.write("Testtest2") 

    pyautogui.press("enter") 

    dlg_new_save = app.window(title='Testtest2.txt - Notepad') 

    dlg_new_save.wait('visible') 

 

 

def test_functional_font_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.type_keys("Anton") 

    pic = pyautogui.screenshot() 

    pic.save('Screenshot1.png') 

    for i in "Anton": 

        pyautogui.press('backspace') 

    app.UntitledNotepad.menu_select("Format->Font...") 

    pyautogui.press('backspace') 

    time.sleep(12) 

    pyautogui.write('Algerian') 

    pyautogui.press('enter') 

    app.UntitledNotepad.type_keys("Anton") 

    pic2 = pyautogui.screenshot() 

    pic2.save('Screenshot2.png') 

 

 

def test_functional_print_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Print") 

    dlg_print = app.UntitledNotepad.Print 

    dlg_print.wait('visible') 

    app.UntitledNotepad.Print.Cancel.click() 

    pyautogui.hotkey('ctrl', 'p') 

    pyautogui.press('enter') 

    pyautogui.write("pdftest0") 

    pyautogui.press('enter') 

    app.UntitledNotepad.menu_select("File->Open") 

    dlg_open = app.UntitledNotepad.Ope 

    dlg_open.wait('visible') 

    pyautogui.write('pdftest0.pdf') 

    pyautogui.press('enter') 

    dlg_new_open = app.window(title='pdftest0.pdf - Notepad') 

    dlg_new_open.wait('visible') 

 

 

def test_integration_main_window(): 

    app = Application(backend="uia").start("notepad.exe") 

    dlg_main = app.UntitledNotepad 

    dlg_main.StatusBar.wait('visible') 
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    dlg_main.Edit.wait('visible') 

    dlg_main.TitleBar.wait('visible') 

    dlg_main.ApplicationMenu.wait('visible') 

     

     

def test_integration_open_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Open") 

    dlg_open = app.UntitledNotepad.Open 

    dlg_open.wait('visible') 

    app.UntitledNotepad.Open.Cancel.click() 

    pyautogui.hotkey('ctrl', 'o') 

    dlg_open.wait('visible') 

     

     

def test_integration_save_as_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Save As") 

    dlg_save = app.UntitledNotepad.SaveAs 

    dlg_save.wait('visible') 

    app.UntitledNotepad.SaveAs.Cancel.click() 

    pyautogui.hotkey('ctrl', 's') 

    dlg_save.wait('visible') 

     

     

def test_integration_print_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("File->Print") 

    dlg_print = app.UntitledNotepad.Print 

    dlg_print.wait('visible') 

    app.UntitledNotepad.Print.Cancel.click() 

    pyautogui.hotkey('ctrl', 'p') 

    dlg_print.wait('visible') 

 

 

def test_integration_font_feature(): 

    app = Application(backend="uia").start("notepad.exe") 

    app.UntitledNotepad.menu_select("Format->Font...") 

    dlg_font = app.UntitledNotepad.Font 

    dlg_font.wait('visible') 

    app.UntitledNotepad.Font.Cancel.click() 

    pyautogui.hotkey('ctrl', 'p') 

    dlg_font.wait('visible') 
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ВИВЧЕННЯ МЕТОДІВ ТЕСТУВАННЯ ДЕСКТОПНИХ 

ЗАСТОСУНКІВ 
 

Полубєхін Антон, 
Магістр з інформатики 

Харківський національний університет радіоелектроніки 

 

У сучасному світі розробляється все більше різних інформаційних систем, 

веб та десктопних застосунків. Дані вказують, що у 2020 році було завантажено 

більше, ніж 204 млрд. мобільних програмних засобів, що на 45% більше, ніж 

було у 2016 році. Статистичні показники доводять, що люди почали частіше 

використовувати різні застосунки у повсякденному житті [1–5]. 

Тестування програмного забезпечення – це метод перевірки того, чи 

фактичний програмний продукт відповідає очікуваним вимогам, а також 

переконатися, що програмний продукт без дефектів. Метою тестування 

програмного забезпечення є виявлення помилок, прогалин або вимог [6–11]. 

Існує багато видів тестування, які мають різні функції і для виконання яких 

потрібно мати спеціальні знання. Прийнято класифікувати види тестування. 

Зазвичай, вони розподіляються на нефункціональні (рис. 1) та функціональні. 

 

 
 

Рисунок 1 – Нефункціональні види тестування 

 

Нефункціональне тестування має на меті таку перевірку: як працює 

програмне забезпечення і наскільки добре. 

Дане тестування буває таким [12–18]: 

– тестування локалізації; 

– тестування на відмову та відновлення; 

– сумісності; 

– конфігураційне; 

– інсталяційне; 

– тестування на зручність використання; 
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– тестування інтерфейсу користувача; 

– тестування продуктивності. 

Функціональне тестування перевіряє, що робить програмне забезпечення, 

воно поділяється на [1–3, 9, 11, 19]: 

– функціональне; 

– тестування безпеки; 

– тестування взаємодії. 

Нефункціональне тестування так само важливе, як і функціональне. Обидва 

гарантують, що програмний продукт працює належним чином. 

Однак, нефункціональне тестування перевіряє деталі, які не розглядаються у 

функціональних тестах. 

Насправді класифікацій видів тестування більше, їх можна класифікувати 

таким чином: 

– за часом виконання; 

– за формальністю; 

– за виконанням коду; 

– за рівнями тестування; 

– за виконавцем тестування; 

– за ступенем автоматизації; 

– позитивне і негативне тестування; 

– за знанням системи; 

– за розробкою тестової документації. 

Найчастіше під час тестування десктопних застосунків використовуються 

такі функціональні види тестування: функціональне тестування і тестування 

безпеки. 

Функціональне тестування – це тип тестування програмного забезпечення, 

який перевіряє систему програмного забезпечення на відповідність 

функціональним вимогам або специфікаціям. Метою функціональних тестів є 

тестування кожної функції програмної платформи шляхом надання відповідних 

вхідних даних і перевірки вихідних даних на відповідність функціональним 

вимогам. Функціональне тестування в основному включає тестування чорного 

ящика, і воно не стосується вихідного коду програми. Це тестування перевіряє 

інтерфейс користувача, API, базу даних, безпеку, зв’язок між клієнтом і сервером 

та інші функції програми, що тестується. Тестування можна проводити як 

вручну, так і за допомогою автоматизації. 

Тестування безпеки – це тип тестування програмного забезпечення, який 

виявляє вразливі місця, загрози, ризики в програмному застосунку та запобігає 

атаки зловмисників.  

Метою тестів безпеки є виявлення всіх можливих слабких місць програмної 

системи, які можуть призвести до втрати інформації, доходу, репутації з боку 

співробітників або сторонніх осіб організації. 

З нефункціональних видів тестів використовують: усі види тестування 

продуктивності, локалізації, інсталяційне, конфігураційне, сумісності, 

тестування на зручність використання, тестування інтерфейсу користувача, 
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тестування на відмову та відновлення, а також димове тестування. Особливу 

увагу звертають на продуктивність і тестування інсталяції. 

Тестування продуктивності – це техніка нефункціонального тестування 

програмного забезпечення, яка визначає, наскільки стабільність, швидкість, 

масштабованість і швидкість реагування програми зберігаються при заданому 

робочому навантаженні. Це ключовий крок у забезпеченні якості програмного 

забезпечення, але, на жаль, часто розглядається ізольовано, і розпочинається 

після завершення функціонального тестування, а в більшості випадків – після 

того, як код буде готовий до випуску. 

Тестування продуктивності включає оцінку вихідних даних програми, 

швидкості обробки, швидкості передачі даних, використання пропускної 

здатності мережі, максимальної кількості одночасних користувачів, 

використання пам’яті, ефективності робочого навантаження та часу відповіді на 

команди. 

Тестування навантаження – перевіряє здатність програми працювати в 

умовах очікуваного навантаження користувача.  

Стрес-тестування – передбачає тестування програми за екстремальних 

робочих навантажень, щоб побачити, як вона справляється з великим обсягом 

або обробкою даних.  

Тестування на довговічність – проводиться, щоб переконатися, що програмне 

забезпечення може витримати очікуване навантаження протягом тривалого 

періоду часу.  

Тестування стрибків – перевіряє реакцію програмного забезпечення на 

раптові великі стрибки навантаження, створювані користувачами. 

Об’ємне тестування – перевіряє продуктивність програми в різних обсягах 

бази даних.  

Тестування масштабованості – визначає ефективність програмного 

застосунку в «розширенні» для підтримки збільшення навантаження на 

користувачів. 

Тестування локалізації – це техніка тестування програмного забезпечення, 

яка перевіряє, чи програма або вебсайт пропонує повну функціональність і 

зручність використання в певному регіоні. Якщо продукт налаштовано для 

цільової мови чи регіону, то перевірка локалізації перевіряє точність і 

придатність вмісту. 

Тестування інсталяції виконується, щоб перевірити, чи програмне 

забезпечення правильно встановлено з усіма властивими функціями та чи 

продукт працює відповідно до очікувань. Воно відоме як тестування реалізації, 

виконується на останній фазі тестування перед першою взаємодією кінцевого 

користувача з продуктом.  

Тестування конфігурації – це тип тестування програмного забезпечення, який 

перевіряє продуктивність системи, що розробляється, порівняно з різними 

комбінаціями програмного та апаратного забезпечення, щоб знайти найкращу 

конфігурацію, за якої система може працювати без будь-яких недоліків або 

проблем, відповідаючи функціональним вимогам (рис. 2). 
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Рисунок 2 – Процес конфігураційного тестування 

 

Тестування GUI – це тип тестування програмного забезпечення, який 

перевіряє графічний інтерфейс користувача програмного забезпечення. Мета 

тестування графічного інтерфейсу користувача (GUI) полягає в тому, щоб 

переконатися, що функціональні можливості програмного забезпечення 

працюють відповідно до специфікацій, перевіряючи екрани та елементи 

керування. 

Тестування відновлення – це техніка тестування програмного забезпечення, 

яка перевіряє здатність програмного забезпечення відновлюватися після збоїв, 

таких як програмного або апаратного забезпечення, мережі тощо. Мета 

тестування відновлення – визначити, чи можна продовжувати роботу 

програмного забезпечення після аварії або втрати цілісності. Тестування 

відновлення передбачає повернення програмного забезпечення до точки, коли 

була відома цілісність, а також повторну обробку транзакцій до точки збою. 
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